Recent Posts

Pages: 1 [2] 3 4 ... 10
11
Tires / Re: Rim Strip?
« Last post by Vewsmewa on November 13, 2019, 12:42:10 am »
The feeling of me now is very glad to be with everyone here.
12
690 Discussion / Re: Help needed....PLEASE !!
« Last post by Vewsmewa on November 13, 2019, 12:35:46 am »
I just knew it was this. If anyone has a question I can answer it. Maybe I will know some things.
13
General Maintenance / Re: Spark Plugs - for a 2014
« Last post by Yuzukakas on October 16, 2019, 04:40:11 am »
It looks like the page will load faster than the last time I entered.
14
General Maintenance / Re: GPS WIRING HELP NEEDED
« Last post by Yuzukakas on October 16, 2019, 04:38:29 am »
It's no wonder that Vell has such a responsive membership that it can get there.
15
Introductions / Re: Checkin in from SoCal
« Last post by Yuzukakas on October 16, 2019, 04:37:51 am »
It is not surprising that this time I have helped you on such good is
16
General Maintenance / Re: Spark Plugs - for a 2014
« Last post by Bornjames on October 10, 2019, 02:53:03 am »
Is very good information
17
Lighting & Electrical / Relay buzzing and engine does not start
« Last post by ianshil on October 04, 2019, 08:20:10 pm »
Hi all,

I have a KTM 690 enduro from 2009, and since recently I have a recurrent problem. When I push the start button here is what happens:
  • either the engine starts, all good  ;D
  • or it does not start and I hear a buzz coming from one of the relays under the seat (I checked: it is the CM1A-R-12V-H80 7)  :(
So when the second case happens, I simply re-push the button or turn off the bike, and then on and re-push the button. After several repetitions the bike eventually starts (on average I'd say that the engine starts 1/10 times). My first thought was to change the relay, which I did, but the problem is still there. No noticeable change since there, the situation is pretty similar. Anyone has an idea of what it could be? I am starting to think that it might be the battery but I have no solid knowledge in electrical stuff, so I prefer asking!

Thanks a lot for your help guys!
18
Armor Up! / Re: Adventure Spec Side Case Covers
« Last post by Outlaw6Guy on September 28, 2019, 11:50:48 am »
Look good.... but have questions...
How thick are they?  In other words, do the levers make contact with normal use?
Looks like it is clear coated - do you think it might be easily ****? (exposing carbon fibres)

Nice sprocket cover. Hoe's it holding up for you?
19
For Sale / Wanted / Re: Well......I might as well be the first!
« Last post by Outlaw6Guy on September 28, 2019, 11:40:03 am »
I only have 4 of these left. They are all black anodized, no orange ones left. Anyone interested IM me. I'll make a special price for the last 4.
20
What Broke? / Re: OEM seat <a href=
« Last post by disbanded on July 14, 2019, 06:47:52 pm »
I came across 3 extra seat bumpers on the 690 that are used between the stock skid plate and engine.

When you go to change your skid plate... Boom!, 3 extra seat bumpers!
Pages: 1 [2] 3 4 ... 10