Author Topic: clutch plates grabbing?  (Read 26 times)

renpar

  • Wanderer
  • *
  • Posts: 2
  • Karma: +0/-0
  • Location: australia
    • View Profile
clutch plates grabbing?
« on: April 14, 2018, 03:37:30 am »
Hi guys, i recently burnt out my clutch on an over night camping trip and was able to just make it to the nearest town to get a bus home. I retreived my bike a few days later and put a new clutch plates in and it's going great. very responsive and feels like a new bike. My only problem is that when i have the bike on a stand and put it in gear, the wheel spins as fast as it does with the clutch engaged. If i pull the clutch and lean on the bike to put the rear wheel on the ground it will stop spinning, but only just. As soon as i raise the wheel it begins spinning just as fast. It did this before i burnt the clutch out but no where nearly as much. Also, it a little harder to get it to neutral when i stoped at the lights
there's also a tapping noise i can hear when the clutch is engaged (lever not pulled). it seems to go away when i pull the lever.
It's a 2010 model with 10k km
is this caused by
1. the clutch rod not pushing enough?
2. the clutch plates are brand new and gripping a lot because i haven't been for good offroad ride yet?
3. i've done something wrong with the install?

cheers, Rene

Share on Facebook Share on Twitter Share on Google+


Yodasaki

  • Wanderer
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Re: clutch plates grabbing?
« Reply #1 on: April 20, 2018, 12:28:13 am »
The information is very interesting.